Windows: Objectivity/C++ Configuration

Printer-friendly version

To configure Objectivity/C++, refer to the following:

Setting Up the Visual C++ IDE

To set up the Visual C++ IDE to work with Objectivity/C++ and Objectivity/DDL, you must set the search path to find various Objectivity/C++ files.

Setting the Visual C++ 9.0 IDE Search Paths

  1. Choose Tools > Options, expand Projects and Solutions, and then select the VC++ Directories property page.
  2. In the Show Directories For list, click Include files and enter the following path in the Directories list:
    installDir\include
  3. In the Show Directories For list, click Executable files and enter the following path in the Directories list:
    installDir\bin
  4. In the Show Directories For list, click Library files and enter the following path in the Directories list:
    installDir\lib

Setting the Visual C++ 10.0 IDE Search Paths

Visual C++ 10.0 lets you set search paths on a per project basis, or globally for all projects for a given user on a given machine.

To set search paths for a particular project:

  1. Open the project for which you want to set the search paths.
  2. In the Solution Explorer, right click on the project name and choose Properties to access the Property Pages dialog.
  3. Choose the configuration for which you want to set the search paths, for example, All Configurations and Win32.
  4. Click the VC++ Directories Configuration Property.
  5. Set the Search paths:
    • Click Executable Directories, then click the downward arrow to the right of the text-entry field, choose Edit from the drop-down menu, then click the folder icon and add the following path:
      installDir\bin
    • Click Include Directories, then click the downward arrow to the right of the text-entry field, choose Edit from the drop-down menu, then click the folder icon and add the following path:
      installDir\include
    • Click Library Directories, then click the downward arrow to the right of the text-entry field, choose Edit from the drop-down menu, then click the folder icon and add the following path:
      installDir\lib

To set search paths globally:

  1. Open any VC++ 10 project.
    The settings will be global—it doesn’t matter which project you open.
  2. From Visual Studio, choose View > Other Window > Property Manager.
    The Property Manager menu might be directly on the View menu, depending on your Visual Studio profile.
  3. In the Property Manager pane, expand the type of build for which you want to set global search paths, for example, Release | Win32.
  4. Double click on Microsoft.Cpp.Win32.user to access a property page for setting global search paths.
  5. Click VC++ Directories under Common Properties.
  6. Specify the search paths as described above.

Setting the Visual C++ 11.0 IDE Search Paths

See Setting the Visual C++ 10.0 IDE Search Paths.

Testing Objectivity/C++ Setup

If you installed both Objectivity/C++ and Objectivity/DDL, you can test whether they are set up correctly by using your Visual C++ IDE to build and run the HelloWorld sample application provided with the installation. Refer to the readme file in:

installDir\samples\cxx\helloWorld

Developing Objectivity/C++ Applications using Visual C++

For instructions on how to set up your own Visual C++ project, see C++ Application Development.

If you want to learn how to use various Objectivity/C++ features, consider downloading and running some of the sample C++ applications.



 

Date: 
Monday, August 20, 2012
Product: 
Objectivity/DB
Version: 
11.0