Supported Configurations - Objectivity/DB 10.2.X

Printer-friendly version

Supported configurations for our previous release.

WindowsWindows Compiler 32-bit 64-bit 5
Windows 7 VC10 Certified Download Available 1 Certified Download Available 1,6
VC9 Certified Download Available 2 Certified Download Available 2,6
VC8 Supported but Not Certified 3 Unavailable
Windows Server 2008 (2008R2 64-bit) VC10 Supported but Not Certified 1,4 Supported but Not Certified 1,6
VC9 Supported but Not Certified 2,4 Certified Download Available 2,6
Windows Server 2008 VC8 Supported but Not Certified 3,4 Unavailable
Windows Server 2003 VC8 Supported but Not Certified 1,4 Unavailable
Windows XP VC10 Supported but Not Certified 1,5 Unavailable
VC9 Supported but Not Certified 2,5 Supported but Not Certified 2,4,6
VC8 Certified Download Available 3,5 Unavailable

Footnotes (R10.2.X):
1 - .NET Framework 4.0 must be installed
2 - .NET Framework 3.5 must be installed
3 - .NET Framework 2.0 or higher must be installed
4 - Service Pack 2
5 - Service Pack 3
6 - Enterprise Java Beans (EJB) unavailable on this platform


Mac OSMac OS Compiler 32-bit 64-bit
Mac OS X 10.7 gcc 4.2.1 Unavailable Certified Download Available 1,2,7
Mac OS X 10.6 gcc 4.2.1 Unavailable Certified Download Available 1,2,8
LinuxLinux 5 Compiler 32-bit 64-bit
RHEL 4/5, SUSE V11(SP1) gcc 3.4.6 or higher Certified Download Available Unavailable
gcc 4.1 or higher Supported but Not Certified Certified Download Available
SUSE V10 (SP2,SP3) gcc 3.4.6 or higher Supported but Not Certified Unavailable
SolarisSolaris Compiler 32-bit 64-bit
Sun Solaris 10 (Sun Solaris x86/AMD Opteron) Studio 11/C++5.8 Unavailable Certified Download Available 2,3
Sun Solaris 10 (SPARC) Studio 12 6 Supported but Not Certified Certified Download Available 2,3
Studio 11 6, 10 6 Certified Download Available Unavailable
Sun Solaris 9 (SPARC) Studio Forte 6 Update 2/C++ 5.3 6 Supported but Not Certified Supported but Not Certified 2,3
HPUXHPUX Compiler 32-bit 64-bit
HP-UX 11iv3 aCC 6.12 Unavailable Certified Download Available 2,4
HP-UX 11iv1 A.03.39 (with AA-flag) Supported but Not Certified 2 Unavailable

Footnotes (R10.2.X):
1 - SQL unavailable on this platform
2 - Objectivity/Assist (compatible with Eclipse 3.5) unavailable on this platform
3 - Enterprise Java Beans (EJB) unavailable on this platform
4 - Active Schema for Java (ASJ) unavailable on this platform
5 - Compatible with most Linux distributions
6 - Certified Compiler Only: issues reported with any newer compiler (supported by Sun) will also be addressed
7 - Mac Lion OS certified with Java JDK 1.6.0_26
8 - Mac Snow Leopard OS certified with Java JDK 1.6.0_24

Specific Product Requirements (if applicable and unless otherwise noted):

Objectivity for Java (OFJ) - Java JDK 1.6.0_19 (not to exceed 1.6.0_xx)
Objectivity/SQL++ (Objectivity/ODBC) - SQL/ODBC 7.4
Python - Python 2.7.2

Date: 
Wednesday, August 8, 2012
Product: 
Objectivity/DB
Version: 
10.2
10.2.1